Friday, October 10, 2014

Pale Moon Version 25.0 Released

Pale Moon
Pale Moon has released version 25.0, which is a major upgrade from version 24x.

It is important to note that Pale Moon 25.0 will not run on Windows XP*.  An exception is the specialized Atom build because of limited operating system availability on netbooks and the like. More details on the dedicated page for this change.

*Update: For those stuck with Windows XP, via Moon Child on the Pale Moon Facebook page,
"Windows XP users may be happy to know about this fully endorsed version specifically for Windows XP! Both x86 and x64 supported.  Pale Moon for Windows XP - Software - Binary Outcast"

See this page for Known Incompatible Add-ons - Add-ons - Pale Moon.  Note that although AdBlock Plus is shown as incompatible, it does indeed work.  However, to edit the filters, it is necessary to open the Add-ons tab and click the icon to change filter options.

Update 2:  Although AdBlock Plus was continuing to block ads for me on Pale Moon version 25 (since I wasn't seeing ads on websites that I know have them) check this out from Adblock Plus (Pseudo-Static) - Add-ons - Pale Moon

"About: This Pseudo-Static release provides users of Pale Moon a fully functional ABP experence while we work with the Adblock Plus team to get Pale Moon officially supported.


By: Adblock Plus Team (Modified by Pale Moon Add-ons Team)

Version: 2.4.6-pm
Compatible with Pale Moon 25.*

Update 3:  See Moon Child's explanation, Why do some extensions no longer work in v25?.

The list of changes to Pale Moon version 25 is extremely long.  Detailed information about this new version is available in the Announcement.

Security fixes:

  • Properly derive/insert the host of a URL
  • Avoid negative audio ratios (can lead to crashes) (CVE-2014-1565)
  • Avoid some root hazards in the style parser
  • Add is-object check to IonBuilder::makeCallHelper (CVE-2014-1562)
  • Clear the jumplist icon cache when history is cleared (privacy fix)
  • Crash fix on Windows (JS JIT) (CVE-2014-1554)
  • Prevent buffer overrun in text directionality component (CVE-2014-1567)
  • Update NSS to (CVE-2014-1568)

Minimum system Requirements (Windows):
  • Windows Vista/Windows 7/Windows 8/Server 2008 or later
  • A processor with SSE2 support
  • 256 MB of free RAM (512 MB or more recommended)
  • At least 150 MB of free (uncompressed) disk space
Pale Moon includes both 32- and 64-bit versions:


To get the update now, select "Help" from the Pale Moon menu at the upper left of the browser window.  Select About Pale Moon > Check for Updates.

Remember - "A day without laughter is a day wasted."
May the wind sing to you and the sun rise in your heart...

1 comment:

sIDcORK said...

Thanks for publishing this.

It should be noted that some Add-ons will not work at present, the developer and many volunteers are working hard to fix the problems.

There is a list of known problems here
and discussion of what's being done on the forums here